use strict;
my $str = 'case 1, only number and unit: 1mA
case 2, number and unit, space: 1mA current
case 3, number and unit, punctuation: 1mA,
case 4, number and unit, Unicode characters: 1mA电流I
case 1, only number and unit: 10mA
case 2, number and unit, space: 100mA current
case 3, number and unit, punctuation: 10 mA ,
case 4, number and unit, Unicode characters: 1000 mA电流I ';
my $regex = qr/([0-9]+)(\s+)?(?=mA)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}