import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([0-9]+)(\\s+)?(?=mA)";
final String string = "case 1, only number and unit: 1mA\n"
+ "case 2, number and unit, space: 1mA current\n"
+ "case 3, number and unit, punctuation: 1mA,\n"
+ "case 4, number and unit, Unicode characters: 1mA电流I \n"
+ "case 1, only number and unit: 10mA\n"
+ "case 2, number and unit, space: 100mA current\n"
+ "case 3, number and unit, punctuation: 10 mA ,\n"
+ "case 4, number and unit, Unicode characters: 1000 mA电流I ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}