$re = '/([0-9]+)(\s+)?(?=mA)/m';
$str = 'case 1, only number and unit: 1mA
case 2, number and unit, space: 1mA current
case 3, number and unit, punctuation: 1mA,
case 4, number and unit, Unicode characters: 1mA电流I
case 1, only number and unit: 10mA
case 2, number and unit, space: 100mA current
case 3, number and unit, punctuation: 10 mA ,
case 4, number and unit, Unicode characters: 1000 mA电流I ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);