const regex = /([0-9]+)(\s+)?(?=mA)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([0-9]+)(\\s+)?(?=mA)', 'gm')
const str = `case 1, only number and unit: 1mA
case 2, number and unit, space: 1mA current
case 3, number and unit, punctuation: 1mA,
case 4, number and unit, Unicode characters: 1mA电流I
case 1, only number and unit: 10mA
case 2, number and unit, space: 100mA current
case 3, number and unit, punctuation: 10 mA ,
case 4, number and unit, Unicode characters: 1000 mA电流I `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}