import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\((\\s*([a-z0-9\\*_]+\\s+[a-z0-9\\*_]+)\\s*),(\\s*([a-z0-9\\*_]+\\s+[a-z0-9\\*_]+)),(\\s*([a-z0-9\\*_]+\\s+[a-z0-9\\*_]+)),(\\s*([a-z0-9\\*_]+\\s+[a-z0-9\\*_]+)),(\\s*([a-z0-9\\*_]+\\s+[a-z0-9\\*_]+)),(\\s*([a-z0-9\\*_]+\\s+[a-z0-9\\*_]+)),(\\s*([a-z0-9\\*_]+\\s+[a-z0-9\\*_]+)\\s*)\\)";
final String string = "VOID TEST2(undefined8 param_1,short *param_2,short *param_3,undefined4 param_4,longlong *param_5,int param_6, longlong param_7)\n\n"
+ "BOOL ProcessCreate(\n"
+ " IN BOOL x86,\n"
+ " IN LPWSTR App,\n"
+ " IN LPWSTR CmdLine,\n"
+ " IN DWORD Flags,\n"
+ " OUT PROCESS_INFORMATION* ProcessInfo,\n"
+ " IN BOOL Piped,\n"
+ " IN PANONPIPE DataAnonPipes\n"
+ ") {";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}