import re
regex = re.compile(r"\((\s*([a-z0-9\*_]+\s+[a-z0-9\*_]+)\s*),(\s*([a-z0-9\*_]+\s+[a-z0-9\*_]+)),(\s*([a-z0-9\*_]+\s+[a-z0-9\*_]+)),(\s*([a-z0-9\*_]+\s+[a-z0-9\*_]+)),(\s*([a-z0-9\*_]+\s+[a-z0-9\*_]+)),(\s*([a-z0-9\*_]+\s+[a-z0-9\*_]+)),(\s*([a-z0-9\*_]+\s+[a-z0-9\*_]+)\s*)\)", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("VOID TEST2(undefined8 param_1,short *param_2,short *param_3,undefined4 param_4,longlong *param_5,int param_6, longlong param_7)\n\n"
"BOOL ProcessCreate(\n"
" IN BOOL x86,\n"
" IN LPWSTR App,\n"
" IN LPWSTR CmdLine,\n"
" IN DWORD Flags,\n"
" OUT PROCESS_INFORMATION* ProcessInfo,\n"
" IN BOOL Piped,\n"
" IN PANONPIPE DataAnonPipes\n"
") {")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")