import Foundation
let pattern = #"\((\s*([a-z0-9\*_]+\s+[a-z0-9\*_]+)\s*),(\s*([a-z0-9\*_]+\s+[a-z0-9\*_]+)),(\s*([a-z0-9\*_]+\s+[a-z0-9\*_]+)),(\s*([a-z0-9\*_]+\s+[a-z0-9\*_]+)),(\s*([a-z0-9\*_]+\s+[a-z0-9\*_]+)),(\s*([a-z0-9\*_]+\s+[a-z0-9\*_]+)),(\s*([a-z0-9\*_]+\s+[a-z0-9\*_]+)\s*)\)"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
VOID TEST2(undefined8 param_1,short *param_2,short *param_3,undefined4 param_4,longlong *param_5,int param_6, longlong param_7)
BOOL ProcessCreate(
IN BOOL x86,
IN LPWSTR App,
IN LPWSTR CmdLine,
IN DWORD Flags,
OUT PROCESS_INFORMATION* ProcessInfo,
IN BOOL Piped,
IN PANONPIPE DataAnonPipes
) {
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)