$re = '/\((\s*([a-z0-9\*_]+\s+[a-z0-9\*_]+)\s*),(\s*([a-z0-9\*_]+\s+[a-z0-9\*_]+)),(\s*([a-z0-9\*_]+\s+[a-z0-9\*_]+)),(\s*([a-z0-9\*_]+\s+[a-z0-9\*_]+)),(\s*([a-z0-9\*_]+\s+[a-z0-9\*_]+)),(\s*([a-z0-9\*_]+\s+[a-z0-9\*_]+)),(\s*([a-z0-9\*_]+\s+[a-z0-9\*_]+)\s*)\)/mi';
$str = 'VOID TEST2(undefined8 param_1,short *param_2,short *param_3,undefined4 param_4,longlong *param_5,int param_6, longlong param_7)
BOOL ProcessCreate(
IN BOOL x86,
IN LPWSTR App,
IN LPWSTR CmdLine,
IN DWORD Flags,
OUT PROCESS_INFORMATION* ProcessInfo,
IN BOOL Piped,
IN PANONPIPE DataAnonPipes
) {';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);