// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)\((\s*([a-z0-9\*_]+\s+[a-z0-9\*_]+)\s*),(\s*([a-z0-9\*_]+\s+[a-z0-9\*_]+)),(\s*([a-z0-9\*_]+\s+[a-z0-9\*_]+)),(\s*([a-z0-9\*_]+\s+[a-z0-9\*_]+)),(\s*([a-z0-9\*_]+\s+[a-z0-9\*_]+)),(\s*([a-z0-9\*_]+\s+[a-z0-9\*_]+)),(\s*([a-z0-9\*_]+\s+[a-z0-9\*_]+)\s*)\)").unwrap();
let string = "VOID TEST2(undefined8 param_1,short *param_2,short *param_3,undefined4 param_4,longlong *param_5,int param_6, longlong param_7)
BOOL ProcessCreate(
IN BOOL x86,
IN LPWSTR App,
IN LPWSTR CmdLine,
IN DWORD Flags,
OUT PROCESS_INFORMATION* ProcessInfo,
IN BOOL Piped,
IN PANONPIPE DataAnonPipes
) {";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}