const regex = /\((\s*([a-z0-9\*_]+\s+[a-z0-9\*_]+)\s*),(\s*([a-z0-9\*_]+\s+[a-z0-9\*_]+)),(\s*([a-z0-9\*_]+\s+[a-z0-9\*_]+)),(\s*([a-z0-9\*_]+\s+[a-z0-9\*_]+)),(\s*([a-z0-9\*_]+\s+[a-z0-9\*_]+)),(\s*([a-z0-9\*_]+\s+[a-z0-9\*_]+)),(\s*([a-z0-9\*_]+\s+[a-z0-9\*_]+)\s*)\)/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\((\\s*([a-z0-9\\*_]+\\s+[a-z0-9\\*_]+)\\s*),(\\s*([a-z0-9\\*_]+\\s+[a-z0-9\\*_]+)),(\\s*([a-z0-9\\*_]+\\s+[a-z0-9\\*_]+)),(\\s*([a-z0-9\\*_]+\\s+[a-z0-9\\*_]+)),(\\s*([a-z0-9\\*_]+\\s+[a-z0-9\\*_]+)),(\\s*([a-z0-9\\*_]+\\s+[a-z0-9\\*_]+)),(\\s*([a-z0-9\\*_]+\\s+[a-z0-9\\*_]+)\\s*)\\)', 'gmi')
const str = `VOID TEST2(undefined8 param_1,short *param_2,short *param_3,undefined4 param_4,longlong *param_5,int param_6, longlong param_7)
BOOL ProcessCreate(
IN BOOL x86,
IN LPWSTR App,
IN LPWSTR CmdLine,
IN DWORD Flags,
OUT PROCESS_INFORMATION* ProcessInfo,
IN BOOL Piped,
IN PANONPIPE DataAnonPipes
) {`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}