use strict;
my $str = 'VOID TEST2(undefined8 param_1,short *param_2,short *param_3,undefined4 param_4,longlong *param_5,int param_6, longlong param_7)
BOOL ProcessCreate(
IN BOOL x86,
IN LPWSTR App,
IN LPWSTR CmdLine,
IN DWORD Flags,
OUT PROCESS_INFORMATION* ProcessInfo,
IN BOOL Piped,
IN PANONPIPE DataAnonPipes
) {';
my $regex = qr/\((\s*([a-z0-9\*_]+\s+[a-z0-9\*_]+)\s*),(\s*([a-z0-9\*_]+\s+[a-z0-9\*_]+)),(\s*([a-z0-9\*_]+\s+[a-z0-9\*_]+)),(\s*([a-z0-9\*_]+\s+[a-z0-9\*_]+)),(\s*([a-z0-9\*_]+\s+[a-z0-9\*_]+)),(\s*([a-z0-9\*_]+\s+[a-z0-9\*_]+)),(\s*([a-z0-9\*_]+\s+[a-z0-9\*_]+)\s*)\)/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}