#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)site[.]com\/[^\/]+\/(\d+)"
Local $sString = "site.com/cat/36814-antonov-polnaya-ahineya.html" & @CRLF & _
"site.com/80-90/36460-dobrynin-polnaya-ahineya.html" & @CRLF & _
"site.com/cat/4415-pyryshki.html"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")