import re
regex = re.compile(r"site[.]com\/[^\/]+\/(\d+)", flags=re.MULTILINE)
test_str = ("site.com/cat/36814-antonov-polnaya-ahineya.html\n"
"site.com/80-90/36460-dobrynin-polnaya-ahineya.html\n"
"site.com/cat/4415-pyryshki.html")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")