package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)site[.]com\/[^\/]+\/(\d+)`)
var str = `site.com/cat/36814-antonov-polnaya-ahineya.html
site.com/80-90/36460-dobrynin-polnaya-ahineya.html
site.com/cat/4415-pyryshki.html`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}