using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"site[.]com\/[^\/]+\/(\d+)";
string input = @"site.com/cat/36814-antonov-polnaya-ahineya.html
site.com/80-90/36460-dobrynin-polnaya-ahineya.html
site.com/cat/4415-pyryshki.html";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}