$re = '/site[.]com\/[^\/]+\/(\d+)/m';
$str = 'site.com/cat/36814-antonov-polnaya-ahineya.html
site.com/80-90/36460-dobrynin-polnaya-ahineya.html
site.com/cat/4415-pyryshki.html';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);