re = /site[.]com\/[^\/]+\/(\d+)/m
str = 'site.com/cat/36814-antonov-polnaya-ahineya.html
site.com/80-90/36460-dobrynin-polnaya-ahineya.html
site.com/cat/4415-pyryshki.html'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end