using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[\]a-zA-Z0-9]\[([^\.\]]+)\]([\[a-zA-Z0-9])?";
string input = @"should pass
$test[2]
$test.var2[4]
$test[0].var3.var4
$test[30].var5[30][3333].var6
$test[0].var7[3][4]
$test[0].var8.var9.var10
below should not pass
$test.var1
$test.var1.asd
test[]
test [0]
test/[0]
test/[0]/
test.[0]
";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}