import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[\\]a-zA-Z0-9]\\[([^\\.\\]]+)\\]([\\[a-zA-Z0-9])?";
final String string = "should pass\n"
+ "$test[2]\n\n"
+ "$test.var2[4]\n"
+ "$test[0].var3.var4\n"
+ "$test[30].var5[30][3333].var6\n"
+ "$test[0].var7[3][4]\n"
+ "$test[0].var8.var9.var10\n\n"
+ "below should not pass\n"
+ "$test.var1\n"
+ "$test.var1.asd\n"
+ "test[]\n"
+ "test [0]\n"
+ "test/[0]\n"
+ "test/[0]/\n"
+ "test.[0]\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}