const regex = /[\]a-zA-Z0-9]\[([^\.\]]+)\]([\[a-zA-Z0-9])?/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[\\]a-zA-Z0-9]\\[([^\\.\\]]+)\\]([\\[a-zA-Z0-9])?', 'gi')
const str = `should pass
\$test[2]
\$test.var2[4]
\$test[0].var3.var4
\$test[30].var5[30][3333].var6
\$test[0].var7[3][4]
\$test[0].var8.var9.var10
below should not pass
\$test.var1
\$test.var1.asd
test[]
test [0]
test/[0]
test/[0]/
test.[0]
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}