import re
regex = re.compile(r"[\]a-zA-Z0-9]\[([^\.\]]+)\]([\[a-zA-Z0-9])?", flags=re.IGNORECASE)
test_str = ("should pass\n"
"$test[2]\n\n"
"$test.var2[4]\n"
"$test[0].var3.var4\n"
"$test[30].var5[30][3333].var6\n"
"$test[0].var7[3][4]\n"
"$test[0].var8.var9.var10\n\n"
"below should not pass\n"
"$test.var1\n"
"$test.var1.asd\n"
"test[]\n"
"test [0]\n"
"test/[0]\n"
"test/[0]/\n"
"test.[0]\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")