#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "([\d\(][\(\)\s\.\-\d]{4,}\d)"
Local $sString = "whatever 0 (000) 000-0000 whatever whatever 0(000)000-0000 whatever" & @CRLF & _
"whatever (000) 000-0000 whatever whatever (000)000-0000 whatever" & @CRLF & _
"whatever 000 000-0000 whatever whatever 000.000.0000 whatever" & @CRLF & _
"whatever 000-42000-0000 whatever whatever 000-0000 whatever" & @CRLF & _
"whatever 000 - 0000 whatever whatever 000.0000 whatever" & @CRLF & _
"whatever 000 . 0000 whatever whatever 000 0000 whatever 1" & @CRLF & _
"whatever 00000000000 whatever" & @CRLF & _
"whatever 0000000000 whatever" & @CRLF & _
"whatever 000000000 whatever" & @CRLF & _
"whatever 00000000 whatever" & @CRLF & _
"whatever 0000000 whatever" & @CRLF & _
"whatever 000000 whatever" & @CRLF & _
"whatever 00 00 0000 0000 whatever 3" & @CRLF & _
"whatever 00 0000 000 000 whatever 3" & @CRLF & _
"whatever 000 0000 0000 whatever 2" & @CRLF & _
"whatever (000) 0000 0000 whatever" & @CRLF & _
"whatever 00000 000000 whatever 1" & @CRLF & _
"whatever 00 0000 0000 whatever 21135"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")