use strict;
my $str = 'whatever 0 (000) 000-0000 whatever whatever 0(000)000-0000 whatever
whatever (000) 000-0000 whatever whatever (000)000-0000 whatever
whatever 000 000-0000 whatever whatever 000.000.0000 whatever
whatever 000-42000-0000 whatever whatever 000-0000 whatever
whatever 000 - 0000 whatever whatever 000.0000 whatever
whatever 000 . 0000 whatever whatever 000 0000 whatever 1
whatever 00000000000 whatever
whatever 0000000000 whatever
whatever 000000000 whatever
whatever 00000000 whatever
whatever 0000000 whatever
whatever 000000 whatever
whatever 00 00 0000 0000 whatever 3
whatever 00 0000 000 000 whatever 3
whatever 000 0000 0000 whatever 2
whatever (000) 0000 0000 whatever
whatever 00000 000000 whatever 1
whatever 00 0000 0000 whatever 21135';
my $regex = qr/([\d\(][\(\)\s\.\-\d]{4,}\d)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}