import re
regex = re.compile(r"([\d\(][\(\)\s\.\-\d]{4,}\d)")
test_str = ("whatever 0 (000) 000-0000 whatever whatever 0(000)000-0000 whatever\n"
"whatever (000) 000-0000 whatever whatever (000)000-0000 whatever\n"
"whatever 000 000-0000 whatever whatever 000.000.0000 whatever\n"
"whatever 000-42000-0000 whatever whatever 000-0000 whatever\n"
"whatever 000 - 0000 whatever whatever 000.0000 whatever\n"
"whatever 000 . 0000 whatever whatever 000 0000 whatever 1\n"
"whatever 00000000000 whatever\n"
"whatever 0000000000 whatever\n"
"whatever 000000000 whatever\n"
"whatever 00000000 whatever\n"
"whatever 0000000 whatever\n"
"whatever 000000 whatever\n"
"whatever 00 00 0000 0000 whatever 3\n"
"whatever 00 0000 000 000 whatever 3\n"
"whatever 000 0000 0000 whatever 2\n"
"whatever (000) 0000 0000 whatever\n"
"whatever 00000 000000 whatever 1\n"
"whatever 00 0000 0000 whatever 21135")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")