#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^([0-9]{9}[0-9X]|[A-Za-z][\dA-Za-z]{9})\.([A-Z0-9]{4})\.PC_([0-9]{3})\.jpg$"
Local $sString = "B12345678X.MAIN.PC_042.jpg"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")