use strict;
my $str = 'B12345678X.MAIN.PC_042.jpg';
my $regex = qr/^([0-9]{9}[0-9X]|[A-Za-z][\dA-Za-z]{9})\.([A-Z0-9]{4})\.PC_([0-9]{3})\.jpg$/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}