import Foundation
let pattern = #"^([0-9]{9}[0-9X]|[A-Za-z][\dA-Za-z]{9})\.([A-Z0-9]{4})\.PC_([0-9]{3})\.jpg$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"B12345678X.MAIN.PC_042.jpg"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}