re = /^([0-9]{9}[0-9X]|[A-Za-z][\dA-Za-z]{9})\.([A-Z0-9]{4})\.PC_([0-9]{3})\.jpg$/
str = 'B12345678X.MAIN.PC_042.jpg'
# Print the match result
str.match(re) do |match|
puts match.to_s
end