const regex = /^([0-9]{9}[0-9X]|[A-Za-z][\dA-Za-z]{9})\.([A-Z0-9]{4})\.PC_([0-9]{3})\.jpg$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([0-9]{9}[0-9X]|[A-Za-z][\\dA-Za-z]{9})\\.([A-Z0-9]{4})\\.PC_([0-9]{3})\\.jpg$', '')
const str = `B12345678X.MAIN.PC_042.jpg`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}