import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([0-9]{9}[0-9X]|[A-Za-z][\\dA-Za-z]{9})\\.([A-Z0-9]{4})\\.PC_([0-9]{3})\\.jpg$";
final String string = "B12345678X.MAIN.PC_042.jpg";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}