#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(([A-Za-z]+[,.]?[ ]?|[a-z]+['-]?)+)$"
Local $sString = "fsdfdsd skjadhsajd" & @CRLF & _
"ASDDAS SASSAS" & @CRLF & _
"ASAFDAASQDAF" & @CRLF & _
"dsad3sdsadsad " & @CRLF & _
"Mathias d'Arras" & @CRLF & _
"Martin Luther King, Jr." & @CRLF & _
"Hector Sausage-Hausen" & @CRLF & _
"dhasd537645" & @CRLF & _
"hjg$%$jkdsfkjsdf" & @CRLF & _
"dlksaj@lkdfjs.com" & @CRLF & _
"dlksaj@lkdfjs" & @CRLF & _
"sdasdsadasd'dsad" & @CRLF & _
"M Edwin" & @CRLF & _
"R A T K Ranawaka" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")