package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(([A-Za-z]+[,.]?[ ]?|[a-z]+['-]?)+)$`)
var str = `fsdfdsd skjadhsajd
ASDDAS SASSAS
ASAFDAASQDAF
dsad3sdsadsad
Mathias d'Arras
Martin Luther King, Jr.
Hector Sausage-Hausen
dhasd537645
hjg$%$jkdsfkjsdf
dlksaj@lkdfjs.com
dlksaj@lkdfjs
sdasdsadasd'dsad
M Edwin
R A T K Ranawaka
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}