import Foundation
let pattern = #"^(([A-Za-z]+[,.]?[ ]?|[a-z]+['-]?)+)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
fsdfdsd skjadhsajd
ASDDAS SASSAS
ASAFDAASQDAF
dsad3sdsadsad
Mathias d'Arras
Martin Luther King, Jr.
Hector Sausage-Hausen
dhasd537645
hjg$%$jkdsfkjsdf
dlksaj@lkdfjs.com
dlksaj@lkdfjs
sdasdsadasd'dsad
M Edwin
R A T K Ranawaka
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)