using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(([A-Za-z]+[,.]?[ ]?|[a-z]+['-]?)+)$";
string input = @"fsdfdsd skjadhsajd
ASDDAS SASSAS
ASAFDAASQDAF
dsad3sdsadsad
Mathias d'Arras
Martin Luther King, Jr.
Hector Sausage-Hausen
dhasd537645
hjg$%$jkdsfkjsdf
dlksaj@lkdfjs.com
dlksaj@lkdfjs
sdasdsadasd'dsad
M Edwin
R A T K Ranawaka
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}