import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(([A-Za-z]+[,.]?[ ]?|[a-z]+['-]?)+)$";
final String string = "fsdfdsd skjadhsajd\n"
+ "ASDDAS SASSAS\n"
+ "ASAFDAASQDAF\n"
+ "dsad3sdsadsad \n"
+ "Mathias d'Arras\n"
+ "Martin Luther King, Jr.\n"
+ "Hector Sausage-Hausen\n"
+ "dhasd537645\n"
+ "hjg$%$jkdsfkjsdf\n"
+ "dlksaj@lkdfjs.com\n"
+ "dlksaj@lkdfjs\n"
+ "sdasdsadasd'dsad\n"
+ "M Edwin\n"
+ "R A T K Ranawaka\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}