// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(([A-Za-z]+[,.]?[ ]?|[a-z]+['-]?)+)$").unwrap();
let string = "fsdfdsd skjadhsajd
ASDDAS SASSAS
ASAFDAASQDAF
dsad3sdsadsad
Mathias d'Arras
Martin Luther King, Jr.
Hector Sausage-Hausen
dhasd537645
hjg$%$jkdsfkjsdf
dlksaj@lkdfjs.com
dlksaj@lkdfjs
sdasdsadasd'dsad
M Edwin
R A T K Ranawaka
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}