re = /^(([A-Za-z]+[,.]?[ ]?|[a-z]+['-]?)+)$/m
str = 'fsdfdsd skjadhsajd
ASDDAS SASSAS
ASAFDAASQDAF
dsad3sdsadsad
Mathias d\'Arras
Martin Luther King, Jr.
Hector Sausage-Hausen
dhasd537645
hjg$%$jkdsfkjsdf
dlksaj@lkdfjs.com
dlksaj@lkdfjs
sdasdsadasd\'dsad
M Edwin
R A T K Ranawaka
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end