# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^.\K|.(?=.*@)|@.\K|\..*(*SKIP)(*F)|.(?=.*\.)/*/img;t' <<< "abc@gmail.com
fdgdg@yahoo.com
abcsds@gmail.co.uk"