use strict;
my $str = 'abc@gmail.com
fdgdg@yahoo.com
abcsds@gmail.co.uk';
my $regex = qr/^.\K|.(?=.*@)|@.\K|\..*(*SKIP)(*F)|.(?=.*\.)/imp;
my $subst = '*';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";