re = /^.\K|.(?=.*@)|@.\K|\..*(*SKIP)(*F)|.(?=.*\.)/im
str = 'abc@gmail.com
fdgdg@yahoo.com
abcsds@gmail.co.uk'
subst = '*'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result