#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?im)^.\K|.(?=.*@)|@.\K|\..*(*SKIP)(*F)|.(?=.*\.)"
Local $sString = "abc@gmail.com" & @CRLF & _
"fdgdg@yahoo.com" & @CRLF & _
"abcsds@gmail.co.uk"
Local $sSubst = "*"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)