$re = '/^.\K|.(?=.*@)|@.\K|\..*(*SKIP)(*F)|.(?=.*\.)/im';
$str = 'abc@gmail.com
fdgdg@yahoo.com
abcsds@gmail.co.uk';
$subst = "*";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;