import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.\\K|.(?=.*@)|@.\\K|\\..*(*SKIP)(*F)|.(?=.*\\.)";
final String string = "abc@gmail.com\n"
+ "fdgdg@yahoo.com\n"
+ "abcsds@gmail.co.uk";
final String subst = "*";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}