using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\[Widget\(\w*\)\])";
string input = @"[Widget(Test1)] [Widget(Test2)] [Widget(Test3)]
[Widget(Test4)] [Widget(Test5)] [Widget(Test6)]";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}