re = /(\[Widget\(\w*\)\])/
str = '[Widget(Test1)] [Widget(Test2)] [Widget(Test3)]
[Widget(Test4)] [Widget(Test5)] [Widget(Test6)]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end