// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\[Widget\(\w*\)\])").unwrap();
let string = "[Widget(Test1)] [Widget(Test2)] [Widget(Test3)]
[Widget(Test4)] [Widget(Test5)] [Widget(Test6)]";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}