import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\[Widget\\(\\w*\\)\\])";
final String string = "[Widget(Test1)] [Widget(Test2)] [Widget(Test3)]\n"
+ "[Widget(Test4)] [Widget(Test5)] [Widget(Test6)]";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}