$re = '/(\[Widget\(\w*\)\])/';
$str = '[Widget(Test1)] [Widget(Test2)] [Widget(Test3)]
[Widget(Test4)] [Widget(Test5)] [Widget(Test6)]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);