import re
regex = re.compile(r"(\[Widget\(\w*\)\])")
test_str = ("[Widget(Test1)] [Widget(Test2)] [Widget(Test3)]\n"
"[Widget(Test4)] [Widget(Test5)] [Widget(Test6)]")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")