package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\[Widget\(\w*\)\])`)
var str = `[Widget(Test1)] [Widget(Test2)] [Widget(Test3)]
[Widget(Test4)] [Widget(Test5)] [Widget(Test6)]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}